Release Notes Advisories
  • Dark
    Light

Release Notes Advisories

  • Dark
    Light

Overview

This page is an index of advisories related to past and present release versions of Matillion ETL.


1.61.6

Applies to Azure Marketplace images of Matillion ETL (Snowflake, Synapse, Delta Lake).

The Matillion ETL v1.61.6 image on Azure Marketplace is currently unavailable. Users wanting to update via Azure Marketplace are encouraged to instead update to 1.62.x when available.


Log4J Advisory

Applies to all platforms.

We urge users to make themselves aware of our security advisory notes regarding the Log4j vulnerability and how it may affect you:

  1. 14th December 2021
  2. 17th December 2021


Apache Tomcat versions

Applies to all platforms.

When a new version of Matillion ETL is released, it's possible that it may be running on an updated version of Apache Tomcat. Users will need to create a new virtual machine (VM) and migrate their existing resources to the new VM to run Matillion ETL on the most up-to-date version of Apache Tomcat. To check the Tomcat version of your Matillion ETL instance, click HelpSupport Information and then scroll down to -- Tomcat: Version.


Version 1.56.x and PostgreSQL 13

Applies to all platforms.

On November 11th, 2021, PostgreSQL version 9 will be deprecated. Starting with version 1.56 of Matillion ETL, new instances will be shipped with PostgreSQL version 13 as the metadata database. We recommend that users update their PostgreSQL database now to reflect this. To learn more, read Technology upgrade of PostgreSQL.


Version 1.53.x

Applies to Matillion ETL for Snowflake, Matillion ETL for Redshift, and Matillion ETL for BigQuery.

The Pardot Extract component has been deprecated and replaced by a new, same-named Pardot Extract component. The new version of this component uses an OAuth authentication method. Existing jobs that use the deprecated component will persist without any problems.


Version 1.51.x

Applies to all platforms.

Job variables used in imported API Extract Profiles may cause errors. See this tech note for more details and solutions.

The YouTube Query component has been deprecated. When creating new orchestration jobs, please use the YouTube Analytics Query component instead. Existing jobs using the YouTube Query component will continue to work as expected.


Version 1.44.x

Applies to Matillion ETL for Snowflake (AWS, Azure) and Matillion ETL for Redshift.

Users with instances hosted on Microsoft Azure, or Amazon Web Services (AWS), should take note of this security advisory notice relating to Matillion ETL v1.44 instances.


Version 1.42.x

Applies to Matillion ETL for Snowflake, Matillion ETL for Redshift, and Matillion ETL for BigQuery.

If you started your Matillion ETL instance at v1.42.x or earlier and have manually upgraded the Apache Tomcat package to a version newer than 8.5.42, please be aware that upgrading may cause problems. If your Tomcat version has not been changed, your Matillion ETL instance should not be affected; however, we still recommend starting a new instance from the appropriate marketplace to ensure that no further upgrade issues occur.